Bluetooth remote support (AVRCP)

Topics: Developer Forum, User Forum
Jan 22, 2010 at 8:00 PM

I figured out how to get the plugin that enables bluetooth remote support for WMP into the internal player.  It at least works on a Q9H and possibly other Widcomm phones.  If we get some more CLSID's for other phones plugins, we can support them as well.

Jan 22, 2010 at 8:00 PM

oh, and I posted it as a patch

 

Jan 22, 2010 at 9:16 PM

Hmm the Microsoft one looks like its {7AAC2B28-5DD1-4052-81DD-E17114EE96B6} based on the emulator, I'll try to get that to work and maybe post a working exe if anyone's interested

Jan 24, 2010 at 1:30 PM

Great news. I have been wanting to do this as well. How can I make this work on my HTC Touch?

Jan 25, 2010 at 3:00 PM

When I get some time I'll try to get this automated but for now, you have to put your BT Plugin's CLSID  in manually.  To find it, look in your registry at "HKLM\Software\Microsoft\MediaPlayer\UIPlugins".  There should be at least one GUID.  Hopefully, there's a description or a friendly name for the BT plugin, that will tell you which GUID is the plugin.  Checkout the source, and apply the patch I uploaded.  There will be a new file BeyondPod/Objects/BTWMPPlugIn.cs  There will be a definition of the coclass for the plugin:

    [ComImport, GuidAttribute("B71FBD59-38EA-45DF-95EF-9FBE968BF000")]
    class BTWmpPlugin { }
Substitute the GUID you found in the registry for the one above.

 

Feb 8, 2010 at 10:12 AM

Thanks for finally getting this out....  however, how do I apply this patch to my BeyondPod?  Do I need to actually open the source code in Visual Studio and import it?   I have not really tinkered much with the BP source code... 

Thanks - I'd REALLY(!!!!) love to finally get this working - I don't care about manual workarounds - I can tweak my registry....  keeps me from abandoning this great product!

Feb 8, 2010 at 4:01 PM
Edited Feb 8, 2010 at 4:03 PM

I tried adding this into the project (successful), and modifying the CLSID (successful), but no Bluetooth controls in BeyondPod yet...

@queler - my AD2 CLSID also shows {7AAC2B28-5DD1-4052-81DD-E17114EE96B6} as the "Windows Media Player Mobile A2DP Plugin, but it still doesn't work - have you been able to get this working?

I am using an HTC Touch (WinMo 6.1 Professional)

 

Feb 8, 2010 at 4:15 PM

If it helps, here is my WMP tree from my registry (Windows Mobile 6.1 Professional, on HTC Touch)

 

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins]

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins\{71D48166-0A7A-4C63-86AF-35DB7F5A097C}]
"Capabilities"=dword:00000001
"Description"="res://ResumePlugin.dll/RT_STRING/#103"
"FriendlyName"="res://ResumePlugin.dll/RT_STRING/#102"

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins\{D90516D3-49A8-4497-B322-75A20DA16F52}]
"Capabilities"=dword:00000001
"Description"="MobileShell Media Widget WMP plugin"
"FriendlyName"="MobileShellWMPPlugin"

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins\{7F6A4541-81D6-4991-BE0A-4767DB3B6BBE}]
"Capabilities"=dword:02000001
"Description"="Pasue/resume Media Player when CVSD running"
"FriendlyName"="CVSD Media Player Control Plugin"

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins\{DAD087AB-1E2F-4b3b-BB5F-0F4D6AB630F8}]
"FriendlyName"="HTC WMP Plug-in Today"
"Description"="HTC WMP Plug-in Today"
"Capabilities"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins\{D7D08B8C-E755-4fa9-8E79-139FA379E00E}]
"FriendlyName"="HTC WMP Control Plug-in"
"Description"="HTC WMP Control Plug-in"
"Capabilities"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins\{41D54E59-C077-4015-841C-127661F4A7F8}]
"FriendlyName"="MediaHubMini WMP Plug-in"
"Description"="MediaHubMini WMP Plug-in"
"Capabilities"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\UIPlugins\{7AAC2B28-5DD1-4052-81DD-E17114EE96B6}]
"FriendlyName"="Windows Media Player Mobile A2DP Plugin"
"Description"="Integrates Bluetooth A2DP functionality with Windows Media Player Mobile"
"Capabilities"=dword:02000001

Feb 8, 2010 at 4:52 PM

Hmmm, that sucks.  I really thought it would work the same with the Microsoft Plugin.  Problem with your build maybe? Try this I built it for the Microsoft plugin.  What did you to test it?  Run it from VS?   The only think I can think of is maybe that plugin might derive from IDispatch instead.  If I understood COM well enough though I would have as much trouble as I'm having trying to get the buttons other then pause to do something.

Feb 8, 2010 at 4:58 PM

queler - your newest file works like a champ!  I am not new to the Visual Studio scene, but I am

a) not familiar with C#
b) not familiar with applying patches
c) haven't built any WinMo apps yet - mine are all windows applications.


This is sweet - worked "out of the box" - I would post that to the patches since it's a simple "copy and paste - replace".

NICE WORK!!!!!!

Me and a friend here thank you VERY MUCH!

 

Feb 8, 2010 at 5:06 PM

I am fairly inexperienced so far, for all I know I built the patch wrong.

 

Feb 8, 2010 at 5:17 PM
Edited Feb 8, 2010 at 5:19 PM

OK - here's the weird thing - this new version works perfectly on my HTC Touch - I am using an Altec Lansing bluetooth "receiver" (?) - my friend has a set of Motorola BT headphones.  Mine works - his does not.  LOL

Sucks to be him....  I wonder if there is a different CLSID on his device for his headphones....  if that makes sense - he too has an HTC Touch.

My patch didn't work, obviously, because I probably built it wrong...  LOL.  YOUR patch works 100% for me.

Do you have the entire project with the .cs attached?  Maybe I can try and tweak the CLSID to match his device (if it doesn't use the original WMP id...).

This is getting fun now!  LOL

 

BTW - I am using Visual Studio 2008 with the WinMo 6.0 Standard SDK installed.

Feb 19, 2010 at 1:59 PM

as I understand it, the CLSID is for the WMP plugin, not for the BT headphones.  Maybe his headphones don't support AVRCP?