Beyondpod won't launch

Topics: User Forum
Oct 31, 2009 at 6:27 PM

After using Beyondpod successfully for about 2 months on my new Touch Pro 2 (WM6.1), it suddenly stopped launching.   I downloaded and reinstalled latest version, reinstalled NetCF 3.5, reinstalled both on the device (not storage card) reset multiple times...and nothing.  clicking on the Beyondpod icon causes the wait icon to appear for about 1 second then it goes away and nothing.  There is also no log file that I can find in the program files/beyondpod folder or any of it's subfolders or in the application data folder or anywhere else.

Any help appreciated.

sblevine

 

Coordinator
Oct 31, 2009 at 8:16 PM

One thing you can do is uninstall BeyondPod, and delete (or rename) the BeyondPod directory from both the storage card and the device. That will give you a clean install.

Stefan

Nov 1, 2009 at 1:32 AM
skyntchev wrote:

One thing you can do is uninstall BeyondPod, and delete (or rename) the BeyondPod directory from both the storage card and the device. That will give you a clean install.

Stefan

 I already tried that with no success.  Still not loading.  I have also deleted anything else which was loaded recently which didn't help.  I have installed other podcast player which runs successfully.

Nov 3, 2009 at 10:36 PM
Any other suggestions? isn't it odd for the progam to stop running?
Nov 8, 2009 at 9:46 PM
Can anyone suggest where i can get support for this bug?
Coordinator
Nov 9, 2009 at 10:57 AM

My only guess is that something got broken in the  .NET Compact Framwork install (or prevents the CF to install correctly).  Do other compact framework applications work on your device?  I have never seen issue like that so far so I am really running out of ideas.  If it is a BeyondPod related issue - uninstalling BeyondPod and deleting the BeyondPod folder will reset BeyondPod to its original state that per your post used to work.

Stefan

 

Nov 9, 2009 at 2:32 PM

Well, I removed .net CF 3.5 (again) went through the regtistry, removed all references to it which remained after the uninstall.

When I did a softreset a couple programs complained (theme related programs).  I reinstalled net cf and rebooted.  The complaints went away

so everything seems to be running correctly except for Beyondpod.   Can you point me to some other program which uses net cf I could use as a test?  Is there anything else I can do short of a hard reset if net cf is corrupted with respect to the functions which beyondpod uses?

 

Stuart

Nov 9, 2009 at 3:44 PM

Here's an update since my previous post.

I did a hard reset. installed beyondpod and it worked fine.

THen I installed my other programs and then s2u2 (slide to unlock) with complained that it wanted a later version of net cf. (the version that comes in the T-mobile touch pro 2 is net cf 2.0).  After a soft reboot, i immediately checked beyondpod and it stopped working just like before the hard reset.

Now my recollection from three weeks back, is that there was had NOT installed net cf 3.5 when the trouble started.  It just started out of the blue without any relationship to any other installation.

So now I tried to unstall net cf 3.5 and reinstall 2.0, but it won't let me.  2.0 keeps complaining about an installation of a newer version no matter how I uninstall and cleanup from 3.5. 

I'm inclined to believe that there is some problem with the tp2 and beyondpod + net cf 3.5 which I'm not going to be able to fix, and problably isn't worth your time in fixing since I'm the only one it seems with the problem.

 

 

Nov 9, 2009 at 4:50 PM

I found the problem.  Or more correctly, I found the program causing the problem.  I don't see how they are connected, but I went back and looked at the programs I installed after I installed beyondpod, and found one which I had indeed installed just recently, about the time that beyondpod stopped working. I uninstalled it and now beyondpod works.  The question is: which program is causing the conflict and is "to blame"?

the program is actually a utility which provides hebrew fonts for wm6.1.  It is called:  badnimits_hebrew_nohardkeybrd which I downloaded from xda-developers.

I'll try to get you the email of the developer if you are inclined to discuss the problem with him.

Stuart

Coordinator
Nov 9, 2009 at 4:58 PM

Stuart,

Thanks for digging into that. Can you post  a link where I can get badnimits_hebrew_nohardkeybrd. I will try to download and see if I can debug the problem. I don't think BeyondPod does anything special that can be influenced by that app, but it is possible that it installs (or replaces) some of the system DLLs (... and that confuses the compact framwork 3.5).

Stefan

Nov 9, 2009 at 6:19 PM

here is the link to the page on xda-developers

 

http://forum.xda-developers.com/showthread.php?t=453760