Beyondpod on WM6.5

Apr 20, 2009 at 5:11 PM
Just a heads up. Looks like issues with v3.1.1 and Windows Mobile 6.5. I am using a pre-release version of wm6.5 on my TMobile Wing, and the content page for podcasts does not display well. This is probably because of the new Mobile IE that is part of wm6.5 . There is no scrollbar, and built in finger scrolling does not work at all. I have to use the dpad to "tab" down the links to scroll down. Also, the text is larger than normal (as if zoomed in) and podcast title lines run off screen. Everything else seems to work OK.
Apr 20, 2009 at 10:52 PM
Edited Apr 20, 2009 at 10:56 PM
I see there is some discussion of this in the thread "What controls the display inside each feed?". Unfortunately the title did not specify wm6.5 issues specifically, so i started this new thread. Perhaps this thread can be used for "wm6.5 only" discussions. For anyone seeing this, skyntchev wrote that he is aware of wm6.5 content view issues and is waiting for official release of wm6.5 before working on it.

Note:  On my version of wm6.5, the problem is just with the embedded IE for content view. All other finger scrolling screens work fine. There is a minor skin sizing issue with internal player (QVGA). Player is slightly too tall and the top is truncated.
May 18, 2009 at 2:25 PM
Edited May 18, 2009 at 2:26 PM

It was a wise choice to wait before addressing any WM6.5 issues until an official release. I just updated my phone with a newer build of wm6.5 (still  a leaked beta) and all issues with the embedded IE when viewing podcast content. have disappeared. The finger scrolling works fine and text is correctly sized and word wraps. I am using a custom wm6.5 ROM based on build 21222.

May 18, 2009 at 8:04 PM

I found out that my WM6.5 build only had NetCF2.0. I had to upgrade to NetCF3.5 for another application, and all the Content View issues returned. No finger scrolling, incorrect font sizes, and no word wrap on posting headings.

Coordinator
May 23, 2009 at 1:44 PM

Thanks nonpaq,

I am currently trying to find a good 6.5 rom for my Kaiser (there are so many out there that it is difficult to guess which one will be closest to the release).  Once I get a good ROM (any suggestions ??) I will start digging into the browser issues. Based on your experiments it appears that the 2.0 3.5 CF is to blame. At least this is a good starting point.

Stefan

May 31, 2009 at 5:02 PM

I just installed 6.5 on my htc fuze and I have the same problems stated above.  I did try to downgrade to Pocket Internet Explorer 6.1 but it didn't have any effect on Beyondpod.  PIE 6.1 did break my email and text messaging so I had to do a hard boot my device. 

May 31, 2009 at 8:45 PM

Ive found a fix for this on winmo pro 6.1 systems, It may work on 6.5 too.

It seems to have something to do with a combination of your version of pocket IE and the .net compact framework version thats being used.

so to fix this go in to the beyonpod.exe.config(something like that dont have my phone in front of me) file that's in the program folder and either delete or comment out the line that reffers to .net framework 3.5 leaveing only the 2.x entries.

Id imagine you need the 2.x .net framework installed seprately if you dont have it included in your rom (for me this is the version that was included in the rom and I added 3.5 seprately.

 

Hope this helps and or gives a direction to work in to find where the bug is.

Jun 1, 2009 at 9:11 PM

Thanks, Rootdir.  I tried your suggestion on WM6.5 (Miri 15.0 for Touch HD).  Unfortunately, it did not work.

I think you are 100% correct that it has "something to do with a combination of your version of pocket IE and the .net compact framework version thats being used".  Unfortunately, on Touch HD, most of the ROMs released in the last 3-4 months don't work with BeyondPod.  Lately, the only ones that work for me with BeyondPod are onkolog's Lite & SuperLite versions from xda forums.

It looks like Kinoma is headed in a direction to become a good RSS reader & podcatcher, but they are not nearly as good as BeyondPod yet.  I hope to see a new version of BeyondPod soon that will support these latest combinations of PIE & NetCF that are showing up in 6.1 & 6.5 ROMs.

Jun 1, 2009 at 11:30 PM

sorry it didn't work for you, few suggestions to make sure:

did you make sure the 2.0 .NET CF was installed and also make sure you soft reset after editing the file

if you commented it out make sure you're using proper XML syntax <!--comment-->

 

Ill look and see the exact versions of .NET CF & Pocket IE is making mine work and post them later.

 

oh and one other thought:Why on earth are we using an emmbeded pocket IE anyway?? why not use webkit or KHTML? since all we are doing is rendering a local page we dont need any networking overhead or anything.

 

Id really Like to help with the future development of beyond pod but i dont know my way around visual studio much less the winmo sdk

Jun 2, 2009 at 12:57 AM

Thanks for the suggestions.

I didn't comment the 3.5 out....just deleted it completely.  Then when I restarted BeyondPod, it said I needed 1 of 3 different 2.0 .NET CF versions.  I found a cab for one of the exact ones mentioned....installed it....soft reset.....and tried BeyondPod again.  The behavior inside each feed was the same -- too big, no finger scroll, etc.  Maybe I should try it again or with a different ROM.

Jun 5, 2009 at 9:33 PM

I don't think I can go much longer without a fully functional BeyondPod, so I thought I'd weigh in. I've flashed several 6.5 roms on my Kaiser (HTC TYTN 2) in the past couple months. Today I flashed Josh's latest build (21234), which was ripped from the official 6.5 SDK, technically making it RTM. The .NET CF Config tool says that versions 3.5.7283.0 and 2.0.7045.0 are both installed. I've experienced the same issues as the posters above with every 6.5 build, including the the RTM. Hopefully with the release of the 6.5 SDK skyntchev can get an updated version going for us early adopters.

Here's the link to the 6.5 SDK:

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=20686a1d-97a8-4f80-bc6a-ae010e085a6e

And for Kaiser users, the RTM test release:

http://www.ogware.com/downloads/roms/joshroms/Roms/Kaiser/TESTS/

Coordinator
Jun 7, 2009 at 2:06 AM

I finally found some time to upgrade my old Kaiser to 6.5 and was able to replicate the issues you guys describe. I already started looking for a solution. Unfortunately between work and the support of the Android version I barely have time to spend on the Windows version. Being an open source project, I was hoping that somebody will take the initiative and suggest/implement solutions to both the Google Login issue and the browser scrolling, but unfortunately so far nobody has.

Once I find something I will try to post a new beta.

Stefan

Jun 7, 2009 at 9:51 AM

Thanks, Stefan.  I'm glad to see to hear that you've experienced the issues firsthand . . . and I certainly understand that there's not enough time for you to fix it.  Although it's open source, I simply don't have the skills to tackle this.  I hope someone does.  It's the best podcatcher out there & I hate to see it become obsolete.  Frankly speaking, even if someone doesn't fix it via open source, I think you (Stefan) should think about fixing it for the Windows Mobile marketplace.  I think you could probably make more money via the marketplace than with the Android version.

Good luck to all & I hope to see a fix soon!

Jun 18, 2009 at 1:27 AM

It's sad, but I feel like I'm watching the death of the best podcatcher software in front of my eyes.  There are very few WM6.1 or WM6.5 ROMs available (so far, I've found only 1 from the latest generation of releases) that will let me run BeyondPod on my TouchHD.  There seems to be one other piece of software ("uptodate" -- medical software) that relies on PIE5, but the ROM chefs are basically ignoring these niche needs.  Besides, I suppose it's only right that they use the latest PIE6.

I guess that some of us are early adopters to new ROMs, so this problem may hasn't hit the mainstream yet....but it probably will soon.  What is everyone doing?  Have you found a suitable replacement for BeyondPod?  I've searched, but I don't think there is a decent replacement.  :(

Jun 18, 2009 at 2:52 AM

well I dont have the programing skills to fix this but I might be able to figure out why mines working and yours isn't and from there hack together a solution

okay I looked and the version of .NET CF mine is using and it is 2.0.7045.00

whats the about:version page on your version of pocket ie look like (I acctually seem to have 2 you have to look in your registry to see any extra about:* pages that may exist)

while the two version pages in mine are almost identical theres two minor diffrences one of them the "minor version" is NaN and the other says CE.net.

where is your .NET CF installed and if you can dump the contents of HKEY_LOCAL_MACHINE\Software\Microsoft\.NETCompactFramework  it may be helpful

Coordinator
Jun 18, 2009 at 11:08 AM

I am working on a solution. I have asked in several places  but unfortunately so far nobody seems to know how to fix the issue with the scrolling. I am sure there is a solution It is just matter of time to find it.

Stefan

Jun 29, 2009 at 8:11 PM

Cant wait for a working beyondpod.  i have flashed about 25 different 6.5 roma and have finally cooked an amazing rom that is more solid than any winCE OS that I have run for 15+ yrs. All of my apps are running amazingly well, but beyondpod content view has been exactly the same on every one of them having a messed up content view. There is just no audio podcast software out there that touches Beyondpod. If Beyondpod had a search or simple way to automatically search and add vs cut and paste then there would be no reason to keep searching for a podcasting app. Great work!

Jun 30, 2009 at 1:08 PM

If you'd like I can put a post up in Development and Hacking on XDA to see if anyone would be interested in helping out. I'm sure there are quite a few devs there who use BeyondPod as well and would be willing to contribute.

Coordinator
Jun 30, 2009 at 1:19 PM

Sure! Any help from any source will be appreciated. I was hoping maybe some Microsoft guy can pitch in with info, but no luck so far. I also ran out of support incidents with MS, and they don't seem to go out of their way to help.  You would think with the competition WM is facing they will be willing to support good applications on their platform, but I guess they just don't care (at least for open source ones).

Stefan

 

Jun 30, 2009 at 4:54 PM

@skyntchev

I've posted on XDA looking for developers interested in the project:

http://forum.xda-developers.com/showthread.php?t=531894

As for MS not caring, I really don't think thats the case, their developer support and tools have always been steller. You're right, winmo needs to have high quality apps to remain in the game (one of the reasons I'd like to see BeyondPod live on). Not sure why you're getting the run-around from the support team.

Jul 8, 2009 at 3:57 PM
I seem to have found a temp workaround, which tells me a solution cannot be far off. When I go into content view and cannot see the content or it is messed up. I just switch my touch pro to landsacpe and the view is fine abd I can use the dpad to scroll. I will ususally just shift right back to landscape and the view remains perfect but dpad wont scroll until I first touch the screen, then it will dpad scroll with no problem. I can click and download feeds with no problem. I reduced the large text size in beyondpod settings. All the podcasts manage and playback fine but the volume is much lower than normal hard to hear even with mediaplayer and system volume at max. Volume in my other apps and mediaplayer is very loud as normal.
Coordinator
Jul 10, 2009 at 2:44 AM

bruceo,

Keep in mind that Beyondpod uses its own volume control (by default mapped to up/down on the Dpad)

Stefan

Jul 10, 2009 at 6:36 PM
Edited Jul 10, 2009 at 6:36 PM

Yes I know it controls the WMP volume and then the system has its own.  i am now running a 23001 rom which had touchflo working with 6.5 scrolling which is really nice since I no longer need to have scrollbars, but the content view is still messed up but I can do the landcape flip and it comes back and Dpad scroll is fine, so I am good to go until you come out with the version that works fully. thanks for a tremendous piece of software.

 

On this new rom the volume of beyondpod is back to normal

Sep 22, 2009 at 9:27 PM

The cab file posted here seems to take care of the issue:  http://forum.xda-developers.com/showthread.php?t=555522

BeyondPod & UpToDate both have this problem with some newer ROMS.

 

 

Sep 24, 2009 at 8:11 PM
Edited Sep 24, 2009 at 9:20 PM

The CAB listed by Shirogane has the unfortunate side effect of disabling IE6 in any WM6.5.x build when installed. I took apart the CABs listed in the XDA thread and discovered that is was just replacing the file "shdocvw.dll" in the system directory with an alternate (older?) version. Instead of installing the CAB, I manually copied the shdocvw.dll file (which I extracted from the CAB file) directly into the BeyondPod install directory (SD card in my case). Guess what... it worked!! Now IE6 is uneffected and fully functional, and BeyondPod will use the older dll copied locally. The feed browser does not have the finger scrolling like IE6 has, but at least it has the correct font sizes with wrap around, and you can scroll using the scrollbar on the right side.

This works on a Tmobile Wing with custom WM6.5.1 (build 23047) ROM. Test this on your device to see if the fix is universal. If so, tell skyntchev so he could rebuild the CAB install to include this DLL.

Here is a direct link to just the post with the dll (in zip format):

http://forum.xda-developers.com/showpost.php?p=4601953&postcount=34

 

Sep 24, 2009 at 10:08 PM

Thanks, nonpaq.  I really would like to keep the finger scrolling......and I don't mind losing IE6, since I use Opera 6.7.  The UpToDate thread also has a "Fix IE" that is meant to be installed afterwards, I believe.  I don't use it -- again, since I don't use IE.

With all that said, UpToDate cab is still working for me (with caveats listed) on Touch HD with various 6.5 builds.

Sep 25, 2009 at 2:42 PM
Edited Sep 25, 2009 at 3:02 PM

If I remember correctly,  after the installing the "Fix UpToDate" CAB , Beyondpod did not have finger scrolling in feed content view neither. Finger scrolling works everywhere else, just not where BeyondPod embeds IE (scrolling with your finger just selects the text). The "localized" fix does the same thing, difference is that this "fix" affects only BeyondPod because it is copied locally, and leave IE (or other apps that embed IE) alone.

From what I can tell, the "Fix IE" cab just restores the registry entries to make IE the default browser again. It does nothing to revert the "shdocvw.dll" file replaced with "Fix UpToDate" cab. The other option creates two versions of the dll (the second called "shdocvw2.dll"), then uses Mortscript to change the registry telling WinMobile which to use when IE is launched or embedded. This allows for flipping back and forth. I prefer just copying the dll to the install folder of whatever application needs old IE compatability.

By the way, according to IE Architecture, listed in Wikipedia , "ShDocVw.dll provides the navigation, local caching and history functionalities for the browser."

Sep 25, 2009 at 5:51 PM

I can confirm that copying shdocvw.dll from the FixUpToDate cab to the BeyondPod program directory fixes the 6.5 problem viewing the feed content. Excellent find, BTW. Thank you, nonpaq!

It also seems to fix the problem with "Download All x New Podcasts" link at the top of the feed. Before, it would give me a "page not found" type of error when I followed the link. Now it's working again.

Thanks again!

--James

Oct 2, 2009 at 3:54 PM

Skyntchev, can you build a new beta with the dll included to see if the "fix" works with a fresh installation of the CAB. (Its not really a "fix", more like  forcing a square peg in a round hole. It works, but with limitations. The new IE6 features are basically bypassed.)

Coordinator
Oct 12, 2009 at 11:28 AM

Microsoft finally released a HotFix for that issue (but for some reason I am unable to download it yet).  Once I get it, I will package the hotfix in the build. That shoulod be a at least an "official" solution, rather than hack.

The hotfix is avaialble at:  http://support.microsoft.com/kb/975281.

More information about the post is available at: http://blogs.msdn.com/raffael/archive/2009/09/29/microsoft-released-a-hotfix-for-netcf-v3-5-on-windows-mobile-6-1-4-onwards-to-address-basic-functionalities-of-webbrowser-control.aspx

Stefan

 

Oct 14, 2009 at 10:06 PM

Looks like Microsoft's hot fix is to replace the whole NetCF 3.5 with a patched version to fix the wrapper for ShDocVw.dll. You would need to release and install the full 3.5 framework patch to include the hotfix. They did offer a workaround that can be done in code, by not using the webbrowser control, rather by directly using the two web dlls.

Unfortunately, my ROMs have NetCF 3.7, which also exhibit the problem if I dont add the old ShDocVw.dll file in the local directory. The hotfix wont work for me unless I want to add 3.5 to my device.

Oct 15, 2009 at 9:50 PM

Just as an aside: the local ShDocVw.dll workaround prevents IE from launching when BeyondPod is open. In order to launch IE, I need to exit BeyondPod.

Not a big deal, but I thought I'd mention it.

--James

 

Coordinator
Oct 17, 2009 at 1:39 AM

Microsoft does not make it easy. I still can't get the HotFix. I am hoping that once I get the fix, I can just distribute the new wrapper DLL. In the Android version, I actually replaced the web based feed content view with a view similar to the the one for feeds and podcasts. It appears to work well - this way only the individual post content are displayed in the HTML view which in this case is much simpler.

Stefan

 

Dec 31, 2009 at 1:23 AM

I got that hotfix file from Microsoft, and

this is the link page you can get it. (It's korean Page.)    the center of the page, you can find some bluebutton.

 

http://todaysppc.com/mbzine/bbs/zboard.php?id=pds&page=1&sn1=&divpage=4&sn=off&ss=on&sc=on&select_arrange=headnum&desc=asc&no=27369

Jan 18, 2010 at 1:24 AM

I'm confused. Is there an update to BeyondPod for WM6.5?

Feb 19, 2010 at 4:17 AM

I am using BeyondPod on HTC Touch2 (WM6.5) and it works well for me. I am facing a problem with player. During the playback if a call is received then playback goes into pause and never resumes after the call is over. If I dial out a call then the playback pauses and at the end of call the playback resumes. Is it a problem with my WMP or BeyondPod and how can I fix this?

Apr 21, 2010 at 7:44 PM
Edited Apr 21, 2010 at 7:48 PM

I found a workable fix for content view for WM6.5.5 on XDA-Developers Here .  It involves reverting back the file webview.dll to an earlier version. I tested on a HD2 and it works fine, however it does affect somewhat the formatting of pages in mobile IE. No other side effects experienced so far.

Note: BeyondPod 3.1.1 worked well on WM 6.5.3 and earlier. On WM 6.5.5, the content view is blank because beyondpod can not render the feed's html page. This fix makes the content view render as it did in WM 6.5.3.

Sep 9, 2010 at 11:55 AM

Hi,

I am suffereing same issue in my HD2. Could you please be so kind to confirm that no other second effects happen after changing the webview.dll file? I am using Opera as web browser. Any effect on Opera?

(I imagine that the new file is there for someting (fixing some bugs or allowing new features) so some effects are expected)

Thanks