I found a bug in Version 3.X

Coordinator
Mar 9, 2009 at 11:49 AM
As the old "I Found a Bug" thread is getting too long for CodePlex to handle, we are starting a new one for issues found in  BeyondPod ver. 3.1 and later

Mar 12, 2009 at 3:42 PM
Hi,

I am unable to update feeds via ActiveSync connection and proxy (MS IAS).
The remote server returned an error: (407) Proxy Authentication Required.

Proxy is configured in "Setting-Connections-My Work Network-Proxy Settings". I have tried putting username/password in "Advanced" configuration and removing it. Pocket IE works OK using both options, but BP does not work.
Coordinator
Mar 13, 2009 at 1:13 PM
BeyondPod does not use any special proxy settings. My understanding is that the it uses the same proxy settings Internet Explorer uses, but apparently this is not the case. I need to research that more.

Stefan
Mar 19, 2009 at 7:10 PM
Hi There - I'm not sure if this is a bug or if I'm just messing something up.  I have moved my favorite feeds into the category "Favorites."  When I highlight a feed in the Favorites category, and Menu > Update and Download > Current Category, instead of just updating the current category, it updates the all feeds.  I would like to just update the current feed.

Awesome Software - Cheers!
Mar 22, 2009 at 6:59 PM
Edited Mar 24, 2009 at 10:00 AM
Hi skyntchev,

Thanks for your excellent software - I use it with pleasure.
Two small things
*) When I create a taskusing the Beyond Scheduler and then try to edit the task, it doesn't remember the new settings. Instead the previous settings remain unchanged
*) My Windows Mobile regional settings for the time are 24-h. Using the Beyond Scheduler it's only possible to enter hours based on the 12-h system. It would be great if the Beyond Scheduler would know the regional settings so that it becomes possible to enter 24-h times. Now when I try in the afternoon to set a task for 08:00 in the morning the application presumes I mean 20:00. It's impossible to set the task to start in the morning.

I'm using BeyondPod 3.1.1 on Windows Mobile 6.0 and BeyondScheduler1.3.0.0

Thanks once again,

smilee
Mar 31, 2009 at 10:38 PM
Hi,

I think I found another issue:
The BeyondPod scheduler seems to look for a hardcoded path when it tries to update the feeds (\Program Files\BeyondPod\...)
I use a non-English Windows Mobile phone and therefore the update using the BeyondPod scheduler doesn't work. The application cannot be found

*) Would it be possible for the BeyondPod Scheduler application to extract the correct location of BeyondPod ?
*) How can you update the feeds using for example MortScript, or using certain parameters in a shortcut ? What parameters can you use ?

Thanks in advance,

smilee
Coordinator
Apr 2, 2009 at 7:55 PM
smillee,

Thanks for reporting both issues. You are correct I am not sure why with the 24 hour clock the time picker control behave so strange. I will take a look.
As far as the path, I will probably have to fix it the right way and make it find the "Program files" correctly.
You can start BeyondPod with a parameter  - the name of the category to update (this is what BeyondScheduler does internally)

For example it would be:

  BeyondPod.exe  "Favorites" 

You can add a second parameter "autoexit" if you want BeyondPod to exit after it finishes.

Also, probably it will be easier to just for now create a folder called "\Program Files\BeyondPod\" or "\Storage Card\Program Files\BeyondPod\"  and copy BeyondPod files there. (You can still keep your podcasts in whatever directory they currently reside)

Stefan
Apr 3, 2009 at 12:50 PM

Hi Stefan,

Thanks for your reply.
For some strange reason however I cannot seem to get BeyondPod to update categories. I can start BeyondPod, and with the autoexit parameter it exits perfect.
However when I try to pass parameters like "Favorites", "All feeds" or "news favorites" it does not update anything. It seems like it cannot connect, but there is a WiFi connection present.

I use the following syntax using MortScript (a scripting language for Windows Mobile):
# BeyondPod starts, tries to update (?) but does nothing and exits.
Run("\program files\beyondpod\beyondpod.exe", "Favorites autoexit")
# Same here
Run("\program files\beyondpod\beyondpod.exe", """favorites"" ""autoexit""")
# Same here
Run("\program files\beyondpod\beyondpod.exe", """Favorites"" ""autoexit""")

BeyondPod has the option checked to update feeds through the scheduler.

Thanks in advance,

Smilee
Coordinator
Apr 9, 2009 at 2:56 AM
I don't know how Mort script passes the parameters to the BeyondPod but the first approach looks fine. This is exactly how the scheduler does it. One thing you can try is to create a shortcut with the parameter and see if that works.  Actually, I was thinking that if you have BeyondPod in "\program files\beyondpod\beyondpod.exe" (as in the examples above), the scheduler should be able to start it too.

Stefan
Apr 10, 2009 at 5:58 AM

Hi Stefan,

First of all, great software! 

However, lately I'm getting problem with the autoupdate feature (using the beyondpod scheduler). It started when I flashed my Samsung Omnia SGH-i900 with the new FW DZIA5.This is what I add in the scheduler.

6.00 AM Turn on Wifi
6.01 AM Launch Beyondpod Update
7.45 AM Turn off Wifi

I keep getting constant problems:
1. I can't turn ON/OFF Wifi
2. Myphone goes black and I couldn't wake it up (I had to take out the battery and restart the phone)

I think it has something to do with these factors, (I've been making a lot of experiments but no conclusion yet)
1. GPRS off/on setting
2. Phone sleep setting (I noticed that phone doesn't go to sleep when updating and even after updating  is done)
3. The timing of update, wifi turned off or phone going to sleep

I'm still not giving up on this software yet. I think it's the best out there.

May 4, 2009 at 10:16 AM
Edited May 4, 2009 at 6:56 PM
HI. first of all this is a fantastic application. it just does EVERYTHING you could want.

now the problem. I installed BeyondPod after a rom upgrade and I am now getting the error "beyondPod requires a newer version of windows media player than the one installed on this device"

the media player version is 10.3 build 19960
CF version 3.5
WM 6.1 pro

any suggestions? Thanks in advance

I think I have discovered the problem!! BeyondPod uses the WMP default skin with a small play button. It doesn't like a skin with a large play button. I can't prove this until I get a copy of the old skins.
May 27, 2009 at 3:38 AM

 

Hi Stefan,

Maybe I'm doing something wrong, but I cannot seem to get BeyondPod update itself.

* I unchecked the update using GPRS option

* I only checked the Update using scheduler function

* I can manually perform an update

* When I try to update using the syntax you gave me, the update window briefly shows 'update completed' but does nothing.

I use the following syntax:

Run("\program files\beyondpod\beyondpod.exe", """favorites"" ""autoexit""")

 

Thanks in advance for any tips on this...

May 28, 2009 at 2:15 PM

I've been using Beyond Pod for quite some time now, and up until today I have had no problems.

I hard-booted/reset my HTC Touch this morning, and have started reinstalling applications.  Beyond Pod was the first one I did!  :-)

Now, however, when I try to IMPORT FEEDS from Google Reader, I enter my Google credentials and get the following error:
"An error message cannot be displayed"

Not very descriptive, but that's all that it says.  It also does not move from the "Google user ID and password" screen.

Can anyone tell me what the problem may be?  I have deleted and re-keyed my username and password, as well as removing
and re-installing.  Nothing seems to work now...  am I missing something?

HELP!

Coordinator
May 31, 2009 at 2:02 AM

smilee,

Does the scheduler start any other task (like bluettoth on/off)? Also have you tried to call using Mort Script where the "favorites" is spelled the same way as you see it in BP (e.g. "Favorites" - with capital "F").

Stefan

Coordinator
May 31, 2009 at 2:05 AM

can3gxw,

My guess is that it is a connectivity issue to Google (it happens for some reason from time to time). Have you tried to login when connected thru WiFi? Also you can take a look at the log file (BeyondPodLog.txt - locatad in the BeypondPod install folder). It may have some information about waht is going on.

Stefan

Jun 3, 2009 at 5:39 PM

In reply to can3gxw, issue Can not import Google Reader feeds -

I am having the same issue.  I checked the log file and it said I needed to install netcfv35.messages.en.wm.cab to view the entire message.  After installing, re-trying, and checking the log file, the message appears to be "The remote server returned an error: (404) Not Found." at ... finishGetResponse().

I don't know if Google changed something on their end, like the address you are trying to pull this information from, but hopefully this will help identify the issue.

Jun 7, 2009 at 4:13 PM

I am also getting the google reader connect error.  Also, the message about not being able to display an error message is annoying.  Is there a way to fix this too?  Below is the last entry in BeyondPodLog.txt:

6/7/2009 10:00:49 AM: Unbale to read feed list from Goolge. Reason: System.Net.WebException: An error message cannot be displayed because an optional resource assembly containing it cannot be found
at System.Net.HttpWebRequest.finishGetResponse()
at System.Net.HttpWebRequest.GetResponse()
at svs.Mobile.BeyondMedia.FeedCore.SysIntegration.GoogleReader.CallGoolge()
at svs.Mobile.BeyondMedia.FeedCore.SysIntegration.GoogleReader.LogIn()
at svs.Mobile.BeyondMedia.Opml.LoadGoogleReaderSubscriptions()
at svs.Mobile.BeyondMedia.Opml.OnMenuNext()
at System.Windows.Forms.MenuItem.OnClick()
at System.Windows.Forms.Menu.ProcessMnuProc()
at System.Windows.Forms.Form.WnProc()
at System.Windows.Forms.Control._InternalWnProc()
at Microsoft.AGL.Forms.EVL.EnterModalDialog()
at System.Windows.Forms.Form.ShowDialog()
at svs.Mobile.BeyondMedia.Objects.CommandManager.CmdImportFeeds()
at svs.Mobile.BeyondMedia.Objects.MenuManager.ImportOPML_Click()
at System.Windows.Forms.MenuItem.OnClick()
at System.Windows.Forms.Menu.ProcessMnuProc()
at System.Windows.Forms.Form.WnProc()
at System.Windows.Forms.Control._InternalWnProc()
at Microsoft.AGL.Forms.EVL.EnterMainLoop()
at System.Windows.Forms.Application.Run()
at svs.Mobile.BeyondMedia.Program.Main()

Nov 4, 2009 at 8:29 PM

I installed version 3.1.1 on HTC Tytn II, the windows is in english but the regional settings were Turkish.

When I clicked on a feed all I saw was tags like #Feed_Title# #Feed_Description#, everywhere I could only see these kind of replacement tags. I was crazy searching for it for some time until I figured it must be related with translation, once I made Regional settings Portuguese and restarted the device everything is showing correctly in english :)

So it seems there is an issue with that when you chose Turkish regional settings.

Coordinator
Nov 5, 2009 at 7:10 PM

This is very possible. It is well known that the Turkish settings behave differently than many other regional settings (in terms of screen comparison, up/down casing etc.). Thanks for reporting this issue.

Stefan

 

Dec 27, 2009 at 12:09 PM

Probaby wrong place to put this but im trying 3.1.1 on a touchpro2 running windows 6.5 and although the pods download and play and the rss text appears to download, the screens that should list the rss entries remain blank? the pods are one screen below that and oddly are there...