Downloads Failing

Topics: User Forum
Dec 3, 2008 at 3:09 AM
For some reason over the last couple of months I suddenly have about half my podcasts failing to download. It could be a problem with my carrier (AT&T) although I don't have a problem getting email and other items from my Exchange server. (Using an AT&T/Cingular 8525 running WM6)

I just reformatted my storage card and reinstalled the latest beta, and reimported my feeds from Google Reader so I'd be starting completely from scratch. But I still get many download failures. I have about 10 feeds set up and have about equal success with all of them, sometimes it works, sometimes it doesn't. Sometimes if I force a 3G network disconnect and then reconnect and download it works, sometimes if I quit BP and relaunch it works, sometimes none of those works (as in the following example).

Typically at least when I try to force a download after getting an error, it just says "Connecting" but never goes beyond that. Interestingly I never seem to have a problem getting the actual feed info to update, it's only the podcast downloads.

One example is the NY Times Backstory podcast (http://www.nytimes.com/services/xml/rss/nyt/podcasts/backstory.xml)  - it was set to the default of getting the last 3 podcasts. It got two, but not the third. I just tried to force a download and got this error:

12/2/08 10:48:39 PM: >> Error downloading: http://podcasts.nytimes.com/podcasts/2008/12/01/01backstory-baker.mp3. Reason: System.ObjectDisposedException: ObjectDisposedException
at System.Windows.Forms.Control.InvokeHelper()
at svs.Mobile.BeyondMedia.Objects.ViewManager.ReloadFeedsView()
at svs.Mobile.BeyondMedia.Objects.ViewManager.OnEnclosureDownloadStarted()
at svs.Mobile.BeyondMedia.FeedCore.RSS.EnclosureDownloadManager.OnDownloadStarted()
at svs.Mobile.BeyondMedia.FeedCore.RSS.EnclosureDownloader.OnDownloadStarted()
at svs.Mobile.BeyondMedia.FeedCore.RSS.DownloadAgent.Download()

12/2/08 10:48:40 PM: Fatal Exception Handler: InvalidOperationException
at System.ThrowHelper.ThrowInvalidOperationException()
at System.Collections.Generic.Queue`1.Dequeue()
at svs.Mobile.BeyondMedia.FeedCore.RSS.EnclosureDownloadManager.OnDownloadFailed()
at svs.Mobile.BeyondMedia.FeedCore.RSS.EnclosureDownloader.OnDownloadError()
at svs.Mobile.BeyondMedia.FeedCore.RSS.DownloadAgent.OnDownloadError()
at svs.Mobile.BeyondMedia.FeedCore.RSS.DownloadAgent.Download()

I do love the program though, and it gets better all the time. I still wish it would sort the podcasts based on the feed sorting window, though. For instance I renamed the CNN Headline News podcast with a 1 in front of it to sort to the top of the feed list, and that used to make the podcasts play first, but that stopped maybe 8 months ago or so. Currently it sorts by the name of the podcast which is totally unpredictable.

 Thanks,
Gerry

Coordinator
Dec 3, 2008 at 8:27 PM
Gerry,

Have you tried to download podcasts over WiFi to see if that makes a difference? There was nothing that has changed in the download engine in the recent months and I routinely download between 5 and 10 podcasts a day (but I use EDGE as I don't have a 3G coverage yet).
Also if you see that podcast fails to download, can you check the update log (Menu > Update and Download > View Update Log) It should have some more information about what prevented the download.  At this point my guess is that it is a connection issue, but can be variety of other issues too.

As far as sorting, if you show all podcasts in the category in podcasts view, starting with v3.0 there is a way to group them by feed and within each group the podcasts will be sorted by whatever podcast sort order is for that feed. If you look at the Tips and Tricks page  at www.beyondpod.mobi there is a description on how to turn that on/off.

Stefan
Dec 28, 2008 at 6:52 AM
I'm pretty convinced this is a problem with individual feeds. I've been using these feeds for some time, but something must have changed. Feeds that are working fine (podcasts download without a problem) include CNN News Update, NYTimes Front Page, NPR 10AM News, however the following feeds never download correctly now - NYTimes Backstory, NYT Tech Talk, NYT Science Times.

Taking Backstory for example - http://www.nytimes.com/services/xml/rss/nyt/podcasts/backstory.xml When this tries to download all I get is an 85 byte file that of course won't play. Looking at this file in Notepad, the only readable text includes "Cache-Control" "max-age=0" and "The Requested Page can not be displayed" The odd thing is that I can stream this podcast just fine from within BeyondPod by clicking on the Stream link. And the podcast name about the Download/Play and Stream/Delete links looks fine, and shows around 15MB.

As for sorting, I see what you're referring to, but regardless of the grouping and sorting, the podcasts are always sorted in the order of the podcast name, not the feed name. So with grouping off I just have a list of podcasts without group titles, sorted by podcast name, and with grouping on the podcasts are still sorted by podcast name, but each group of podcasts shows the title of that feed. Here's what I'm trying to do, and I think this worked a few versions back...I have a number of feeds, but I almost always want to listen to the CNN News Update first. So I renamed that feed 1CNN News Update. This sorts that feed at the top of the list in the Feeds view. But when I go to the list of podcasts, these are not sorted at the top - they're somewhere down below determined by the actual name of the podcasts (which I can't control). In this case the podcasts are named by CNN as "CNN News Update (date)" so they're sorted below a bunch of other podcasts that happen to start with numbers. My wish here would be that with Grouping turned on, the sort would go by the feed names, not the podcast names.

Thanks,
Gerry
Coordinator
Dec 28, 2008 at 5:30 PM
Gerry,

I tried the Backstory feed and it downloaded correctly on my device. Can you try if downloading works over WiFi or ActiveSync on your device?

As far as the feed sorting, I think there is a bug in the grouping where for some reason BeyondPod does not sort the feeds (groups) by name. I will fix the in the next build. Once this is fixed it should work the way you want it.

Stefan
Jan 2, 2009 at 3:51 AM
WiFi worked fine! I'll test this again with the G3 connection tomorrow and try to figure out if it's consistently bad with G3 and consistently good on WiFi. I thought I had the messages cab properly loaded, but must not have, so I reinstalled the cab again. Hopefully if it happens again I'll have a better error message to report. Thanks! Gerry
Jan 3, 2009 at 4:39 AM
OK, my G3 downloads are still failing for these same podcasts, and I just proved at home again that WiFi is fine. I won't bore you with the gory details of the hours I spent figuring out which version of CF I have on my WM6 device (turns out to be 2.0), or trying to find the proper file for the error messages (System_SR_enu_wm.cab), then trying to actually figure out where to get that file and how to extract it (I don't even remember now) or the fact that the cab only works if it's installed in main memory. But I -finally- got a useable error message from the download, and it just says "Operation Timed Out."

I also tried deleting the feed and re-adding it manually (I was adding it via Google Reader), but still the same issue. The feed info updates fine, but when it goes to download it tries once for each podcast it knows it needs to download, retries once, then finally errors out with this timeout error. It only happens on these few feeds, it happens consistently on those feeds, and again I can select "Stream" and it plays fine.

I'm trying to remember what might have changed when this all started - I've been downloading these podcasts for a long time, since the early versions of BeyondPod and never had this problem until maybe a couple of months ago or so. Maybe a little longer, Septemberish or Octoberish I guess.

I'll keep toying with different ideas and let you know if I find anything useful.

Gerry
Jan 15, 2009 at 4:44 AM
FWIW, I think I found the problem here. It's evidently the AT&T proxy server. I ran the script to disable the proxy server, and also had to uncheck the Use Proxy setting in the connections area. I think things are working correctly again. I don't know if I inadvertently turned this on when all this started months ago, or if it's been on all along, but AT&T changed something causing the issue with the proxy. In any case I think I'm working again!
Coordinator
Jan 15, 2009 at 11:29 AM
Gerry,

Thank you for posting the solution.
As probably there are others who wight have the same problem, do you mind posting the current proxy settings on your device (what is on/off) and also where to get the script to disable the proxy.

Stefan.
Jan 15, 2009 at 9:14 PM
This is on a "Cingular" 8525 running WM6. In the Programs screen there is a Proxy Manager folder. Inside are two scripts - one to Disable Proxy and one to Restore Proxy. I ran the Disable Proxy. Then I went to Settings/Connections/Connections, under MEdiaNet click Set up my proxy server. In the next screen, uncheck "This network uses a proxy server to connect to the Internet."

I don't know which of those things fixed my problem, but so far it appears that I'm having much fewer download errors.

Gerry