BeyondPod crash on settings

Topics: User Forum
May 28, 2008 at 11:10 PM
When I try to go to Menu>Tools>Settings BeyondPod crashes, giving a brief error message and then exiting. The log entry is as follows:

5/28/08 5:47:13 PM: Fatal Exception Handler: Could not load type 'System.Collections.Generic.KeyValuePair`2' from assembly 'mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=969DB8053D3322AC'.
at svs.Mobile.BeyondMedia.Objects.MenuManager.Settings_Click()

at System.Windows.Forms.MenuItem.OnClick()

at System.Windows.Forms.Menu.ProcessMnuProc()

at System.Windows.Forms.Form.WnProc()

at System.Windows.Forms.Control._InternalWnProc()

at Microsoft.AGL.Forms.EVL.EnterMainLoop()

at System.Windows.Forms.Application.Run()

at svs.Mobile.BeyondMedia.Program.Main()

I'm using a Samsung i760 Windows Mobile 6.0. I have had this installed and working properly in the past (about a month ago). I stopped using it. Removed the program and the associated files/directories, then have since tried to reinstall it. The install goes smoothly and I am able to play podcasts, but just can't get the settings screen to open without crashing.

Martin
May 30, 2008 at 1:00 AM
Edited May 30, 2008 at 1:13 AM
I am having the exact same issue except I am on a Treo 700wx using Windows Mobile 5.  This problem started right after I upgraded to 2.7.1.

UPDATE: I fixed it!  Try reinstalling the .NET Compact Framework version 3.5 on your device.
Coordinator
May 30, 2008 at 10:56 AM


glparker4 wrote:
I am having the exact same issue except I am on a Treo 700wx using Windows Mobile 5.  This problem started right after I upgraded to 2.7.1.

UPDATE: I fixed it!  Try reinstalling the .NET Compact Framework version 3.5 on your device.

This thing is very strange because it works on most devices and it is related somehow to the version of the Compact Framework. I reworked the code a bit in the next build, but never the less that should have worked.  Very, very strange. If somebody still have this problem, can you post what version of the compact framework are you using. (You can find it in Menu->Help->About in BeyondPod).

Stefan
Jun 6, 2008 at 8:51 PM
I have the same problem with 2.7.0.  My Compact Framework is 2.0.6129.0

Phil
Coordinator
Jun 7, 2008 at 11:03 AM


PhilbertG wrote:
I have the same problem with 2.7.0.  My Compact Framework is 2.0.6129.0

Phil


Phil,
Can you please try the latest development build (2.7.1.5). It can be downloaded from http://www.beyondpod.mobi/beta/. I made some changes that hopefully should resolve that problem.  Let me know if that worked for you.

Stefan